Posts Tagged loopback test

Simatic PDM won’t connect to Siemens MultiRanger or HydroRanger

Sometimes I get lazy and don’t follow my own rules. (Rule #1: Test EVERYTHING!)  That one oversight cost me three hours when I could have solved a problem in three minutes. Maybe you can learn from my mistake.

Siemens Multiranger 100 ultrasonic level transceiverThe goof happened at a customer site last week. He had a Siemens MultiRanger 100 ultrasonic level transceiver, and was trying to connect to it via Modbus using Siemens SIMATIC PDM software on his Windows XP laptop PC.

Early on, the Lesman salesman who worked with this customer had connected to the MultiRanger from his laptop using PDM, but only one upload worked successfully. The rest failed. The salesman had lent the customer his “known good” serial cable that he’d used for the successful upload.

Siemens tech support had offered the customer several “Try This/Try That” suggestions, but came to the conclusion that a software program on the customers’ laptop had locked up the laptop’s internal serial port so PDM couldn’t access it. The customer’s IT guy ran a port scan program, but could find on application or service running on COM1. Plus, they’d used the serial port successfully for other connections.

I couldn’t do anything more for the customer over the phone, so I grabbed my serial comms toolkit and headed to the site myself.

Read the rest of this entry »

, , , , , , , , , , , , , , ,

Leave a comment

%d bloggers like this: