Why won’t Pactware work with the Siemens LUT 400?


Written by: Dan Weise

I’ve used Pactware for a couple years now, so I was surprised when I couldn’t get the Siemens LUT400 to work with the software. The LUT400 ultrasonic level and flow controller comes with a DTM file that I installed before opening the Pactware software.

The DTM file can be downloaded from this link: http://tinyurl.com/cqk2cky

Once it had been installed, I opened Pactware and updated the device catalog, as seen in the picture below:

1

But when I attempted to establish a HART connection to the LUT400, I got an error message:

2

I looked in the folder where the file was supposed to be and found a file by that name, but it had a different extension. This file had a .pac extension, as you can see below:

3

A call to Siemens tech support revealed that my LUT400 needed an updated SITRANS DTM driver V3.1.  My Pactware had the older version: 2.1.

If you open the Windows’ Control panel program list (Add or Remove Programs in XP; Programs and Features in Windows 7), you can see the SITRANS DTM program and the version number, as circled below:

4

In order to get the Pactware software to work with the LUT 400, you will need to make sure you have the latest version of SITRANS DTM driver installed.

The V3.1 file (SITRANS_DTM_01_00_00.zip) can be found on the Siemens website on the second page of this link: http://tinyurl.com/btcssrm

5

(Go to page 2 and select the downloadable file circled below)

6

The .msi file in the zipped download SITRANS DTM runs an installer program.

When I tried to install V3.1, I received an error message:

7

Before I could install V3.1, I had to go back to the control panel and uninstall V2.1.

Once V2.1 was uninstalled, V3.1 installed without error and the program appeared in the control panel with the updated version, as you can see below:

8

Now that I had the latest version of SITRANS DTM, I went back to Pactware to try updating its device catalog again.

1

This time, everything worked as usual.  I was able to create an LUT400 project and the LUT400 appeared as all other devices normally do:

9

So, remember: if you’re having trouble getting Pactware to work with the Siemens LUT400, be sure to install the latest version of SITRANS DTM driver.

And if you’re still having difficulty, don’t hesitate to reach out.

Questions? Call (800) 953-7626

Learn more about Siemens LUT400 Ultrasonic Level and Flow Controller at Lesman.com

Lesman Instrument Company is the authorized Siemens representative in Illinois, Indiana, Missouri, Paducah KY, Wisconsin, and Michigan’s Upper Peninsula. If you are located outside that area, you can find your local sales office or get technical assistance by calling 800-365-8766.

===

Dan Weise, Lesman Product SpecialistDan Weise, Lesman product specialist, is an instructor for training classes on process instrumentation hardware, software, and technology.

Dan has been involved in all facets of data acquisition and process instrumentation since 1978, from sales and commissioning to service and support. He’s a long-time member of ISA, and has been with Lesman since 1988.

In his words, Dan’s the guy “who reads all the manuals nobody else reads”. In Lesman customers’ words, he’s the trainer to call if you want to “cut to the SO WHAT of instrumentation”, so it’s easy to understand.

, , , , , , , , , , , ,

  1. Leave a comment

Care to Comment?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: